ORA-00600 on 9i upgrade


You're just about through the upgrade to 9i and the following pops up when you try to open the database:

ORA-600 [qctstc2o1], [3], [1], [1], [1], [4000]

Before you rush up and abuse the poor people at Oracle support, its actually your own fault. Tucked away in the upgrade instructions is a small note that you should NOT set compatible to "9.0.xxx" until the upgrade is fully completed. Of course, the problem here is that if you do not explicitly set it, then you can end with up the same problem.

The resolution is to set

EVENT = "10619 trace name context forever, level 1" 

which overcomes the problem. Once you're finished upgrading, you can remove it.